import Foundation
let pattern = #"^.*?[\\\/]src[\\\/]|([\\\/])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/home/me/projects/project/src/Commands/Interfaces/Whatever
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)