const regex = /^.*?[\\\/]src[\\\/]|([\\\/])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?[\\\\\\\/]src[\\\\\\\/]|([\\\\\\\/])', 'g')
const str = `/home/me/projects/project/src/Commands/Interfaces/Whatever
`;
const subst = `\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);