package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:value[^v]*value=\")([^\"]*)`)
var str = `<input type="hidden" name="loginForm_SUBMIT" value="1" /><input type="hidden" name="faces.ViewState" id="faces.ViewState" value="9uiY/UWJ1/w3PQ==" /></form>
</body>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}