re = /(?:value[^v]*value=\")([^\"]*)/
str = '<input type="hidden" name="loginForm_SUBMIT" value="1" /><input type="hidden" name="faces.ViewState" id="faces.ViewState" value="9uiY/UWJ1/w3PQ==" /></form>
</body>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end