// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:value[^v]*value=\")([^\"]*)"#).unwrap();
let string = "<input type=\"hidden\" name=\"loginForm_SUBMIT\" value=\"1\" /><input type=\"hidden\" name=\"faces.ViewState\" id=\"faces.ViewState\" value=\"9uiY/UWJ1/w3PQ==\" /></form>
</body>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}