use strict;
my $str = '<input type="hidden" name="loginForm_SUBMIT" value="1" /><input type="hidden" name="faces.ViewState" id="faces.ViewState" value="9uiY/UWJ1/w3PQ==" /></form>
</body>';
my $regex = qr/(?:value[^v]*value=\")([^\"]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}