import re
regex = re.compile(r"(?:value[^v]*value=\")([^\"]*)")
test_str = ("<input type=\"hidden\" name=\"loginForm_SUBMIT\" value=\"1\" /><input type=\"hidden\" name=\"faces.ViewState\" id=\"faces.ViewState\" value=\"9uiY/UWJ1/w3PQ==\" /></form>\n"
"</body>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")