# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|([^"]*(?:"[^,"]*"[^"]*)*"))[^",]*\K,([^",]*+(?:"(?1)|$))?/~$2/g;t' <<< "1070,\"17\",2,GN3-670,\"COL,LA,R B, M STAY\",\"2,60,6.45\" ,\","