using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|([^""]*(?:""[^,""]*""[^""]*)*""))[^"",]*\K,([^"",]*+(?:""(?1)|$))?";
string substitution = @"~$2";
string input = @"1070,""17"",2,GN3-670,""COL,LA,R B, M STAY"",""2,60,6.45"" ,"",";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}