use strict;
my $str = '1070,"17",2,GN3-670,"COL,LA,R B, M STAY","2,60,6.45" ,",';
my $regex = qr/(?:\G(?!^)|([^"]*(?:"[^,"]*"[^"]*)*"))[^",]*\K,([^",]*+(?:"(?1)|$))?/p;
my $subst = '~$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";