re = /(?:\G(?!^)|([^"]*(?:"[^,"]*"[^"]*)*"))[^",]*\K,([^",]*+(?:"(?1)|$))?/
str = '1070,"17",2,GN3-670,"COL,LA,R B, M STAY","2,60,6.45" ,",'
subst = '~$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result