$re = '/(?:\G(?!^)|([^"]*(?:"[^,"]*"[^"]*)*"))[^",]*\K,([^",]*+(?:"(?1)|$))?/';
$str = '1070,"17",2,GN3-670,"COL,LA,R B, M STAY","2,60,6.45" ,",';
$subst = "~$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;