import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)|([^\"]*(?:\"[^,\"]*\"[^\"]*)*\"))[^\",]*\\K,([^\",]*+(?:\"(?1)|$))?";
final String string = "1070,\"17\",2,GN3-670,\"COL,LA,R B, M STAY\",\"2,60,6.45\" ,\",";
final String subst = "~$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}