const regex = /(?:\G(?!^)|([^"]*(?:"[^,"]*"[^"]*)*"))[^",]*\K,([^",]*+(?:"(?1)|$))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|([^"]*(?:"[^,"]*"[^"]*)*"))[^",]*\\K,([^",]*+(?:"(?1)|$))?', 'g')
const str = `1070,"17",2,GN3-670,"COL,LA,R B, M STAY","2,60,6.45" ,",`;
const subst = `~$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);