using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?(?:\d+|\D{0}\.\d+)(?:\.\d+)?";
string substitution = @"__";
string input = @"string .001 or -.001 or +.001 or 1.00 or -1.00 or 213 or -213 or 123.132s1 this is rhobust 012";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}