use strict;
my $str = 'string .001 or -.001 or +.001 or 1.00 or -1.00 or 213 or -213 or 123.132s1 this is rhobust 012';
my $regex = qr/[+-]?(?:\d+|\D{0}\.\d+)(?:\.\d+)?/p;
my $subst = '__';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";