const regex = /[+-]?(?:\d+|\D{0}\.\d+)(?:\.\d+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+-]?(?:\\d+|\\D{0}\\.\\d+)(?:\\.\\d+)?', 'g')
const str = `string .001 or -.001 or +.001 or 1.00 or -1.00 or 213 or -213 or 123.132s1 this is rhobust 012`;
const subst = `__`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);