import Foundation
let pattern = #"[+-]?(?:\d+|\D{0}\.\d+)(?:\.\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"string .001 or -.001 or +.001 or 1.00 or -1.00 or 213 or -213 or 123.132s1 this is rhobust 012"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"__"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)