// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[+-]?(?:\d+|\D{0}\.\d+)(?:\.\d+)?").unwrap();
let string = "string .001 or -.001 or +.001 or 1.00 or -1.00 or 213 or -213 or 123.132s1 this is rhobust 012";
let substitution = "__";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}