using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href='(http:\/\/store\.steampowered\.com\/app\/\d+\/)'>";
string input = @"Today's Deal: Save 50% on <a href='http://store.steampowered.com/app/234270/'>Ken Follett's The Pillars of the Earth</a>!*<br><br>Look for the deals each day on the front page of Steam. Or follow us on <a href='http://twitter.com/steam_games'>twitter</a> or <a href='http://www.facebook.com/Steam'>Facebook</a> for instant notifications wherever you are!<br><br>*Offer ends Friday at 10AM Pacific Time<br><a href=\""http://store.steampowered.com/app/234270/\""><img src=\""https://steamcdn-a.akamaihd.net/steam/apps/234270/capsule_467x181.jpg\"" style=\"" float: left; margin-right: 12px; height: 181px; width: 467px;\""></a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}