import re
regex = re.compile(r"<a href='(http:\/\/store\.steampowered\.com\/app\/\d+\/)'>")
test_str = "Today's Deal: Save 50% on <a href='http://store.steampowered.com/app/234270/'>Ken Follett's The Pillars of the Earth</a>!*<br><br>Look for the deals each day on the front page of Steam. Or follow us on <a href='http://twitter.com/steam_games'>twitter</a> or <a href='http://www.facebook.com/Steam'>Facebook</a> for instant notifications wherever you are!<br><br>*Offer ends Friday at 10AM Pacific Time<br><a href=\\\"http://store.steampowered.com/app/234270/\\\"><img src=\\\"https://steamcdn-a.akamaihd.net/steam/apps/234270/capsule_467x181.jpg\\\" style=\\\" float: left; margin-right: 12px; height: 181px; width: 467px;\\\"></a>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")