use strict;
my $str = 'Today\'s Deal: Save 50% on <a href=\'http://store.steampowered.com/app/234270/\'>Ken Follett\'s The Pillars of the Earth</a>!*<br><br>Look for the deals each day on the front page of Steam. Or follow us on <a href=\'http://twitter.com/steam_games\'>twitter</a> or <a href=\'http://www.facebook.com/Steam\'>Facebook</a> for instant notifications wherever you are!<br><br>*Offer ends Friday at 10AM Pacific Time<br><a href=\\"http://store.steampowered.com/app/234270/\\"><img src=\\"https://steamcdn-a.akamaihd.net/steam/apps/234270/capsule_467x181.jpg\\" style=\\" float: left; margin-right: 12px; height: 181px; width: 467px;\\"></a>';
my $regex = qr/<a href='(http:\/\/store\.steampowered\.com\/app\/\d+\/)'>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}