const regex = /<a href='(http:\/\/store\.steampowered\.com\/app\/\d+\/)'>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href=\'(http:\\\/\\\/store\\.steampowered\\.com\\\/app\\\/\\d+\\\/)\'>', 'g')
const str = `Today's Deal: Save 50% on <a href='http://store.steampowered.com/app/234270/'>Ken Follett's The Pillars of the Earth</a>!*<br><br>Look for the deals each day on the front page of Steam. Or follow us on <a href='http://twitter.com/steam_games'>twitter</a> or <a href='http://www.facebook.com/Steam'>Facebook</a> for instant notifications wherever you are!<br><br>*Offer ends Friday at 10AM Pacific Time<br><a href=\\"http://store.steampowered.com/app/234270/\\"><img src=\\"https://steamcdn-a.akamaihd.net/steam/apps/234270/capsule_467x181.jpg\\" style=\\" float: left; margin-right: 12px; height: 181px; width: 467px;\\"></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}