import Foundation
let pattern = #"<a href='(http:\/\/store\.steampowered\.com\/app\/\d+\/)'>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Today's Deal: Save 50% on <a href='http://store.steampowered.com/app/234270/'>Ken Follett's The Pillars of the Earth</a>!*<br><br>Look for the deals each day on the front page of Steam. Or follow us on <a href='http://twitter.com/steam_games'>twitter</a> or <a href='http://www.facebook.com/Steam'>Facebook</a> for instant notifications wherever you are!<br><br>*Offer ends Friday at 10AM Pacific Time<br><a href=\"http://store.steampowered.com/app/234270/\"><img src=\"https://steamcdn-a.akamaihd.net/steam/apps/234270/capsule_467x181.jpg\" style=\" float: left; margin-right: 12px; height: 181px; width: 467px;\"></a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)