#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Tdie.*?\+([\d\.]+)"
Local $sString = "k10temp-pci-00c3" & @CRLF & _
"Adapter: PCI adapter" & @CRLF & _
"Tctl: +56.4°C " & @CRLF & _
"Tdie: +46.4°"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")