package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Tdie.*?\+([\d\.]+)`)
var str = `k10temp-pci-00c3
Adapter: PCI adapter
Tctl: +56.4°C
Tdie: +46.4°`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}