import Foundation
let pattern = #"Tdie.*?\+([\d\.]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
k10temp-pci-00c3
Adapter: PCI adapter
Tctl: +56.4°C
Tdie: +46.4°
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}