const regex = /Tdie.*?\+([\d\.]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Tdie.*?\\+([\\d\\.]+)', '')
const str = `k10temp-pci-00c3
Adapter: PCI adapter
Tctl: +56.4°C
Tdie: +46.4°`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}