re = /Tdie.*?\+([\d\.]+)/
str = 'k10temp-pci-00c3
Adapter: PCI adapter
Tctl: +56.4°C
Tdie: +46.4°'
# Print the match result
str.match(re) do |match|
puts match.to_s
end