import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Tdie.*?\\+([\\d\\.]+)";
final String string = "k10temp-pci-00c3\n"
+ "Adapter: PCI adapter\n"
+ "Tctl: +56.4°C \n"
+ "Tdie: +46.4°";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}