$re = '/Tdie.*?\+([\d\.]+)/';
$str = 'k10temp-pci-00c3
Adapter: PCI adapter
Tctl: +56.4°C
Tdie: +46.4°';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);