#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<tr>)?.*?(?:<td>)(.*?)(?:<\/td>.*?)(?:<\/tr>)?"
Local $sString = "<tr>" & @CRLF & _
" <td><5</td>" & @CRLF & _
" <td>67</td>" & @CRLF & _
" <td>3</td>" & @CRLF & _
" <td>0.1</td>" & @CRLF & _
" <td>0.6</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td><13</td>" & @CRLF & _
" <td>1.2</td>" & @CRLF & _
" <td>2</td>" & @CRLF & _
"</tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")