using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<tr>)?.*?(?:<td>)(.*?)(?:<\/td>.*?)(?:<\/tr>)?";
string input = @"<tr>
<td><5</td>
<td>67</td>
<td>3</td>
<td>0.1</td>
<td>0.6</td>
</tr>
<tr>
<td><13</td>
<td>1.2</td>
<td>2</td>
</tr>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}