$re = '/(?:<tr>)?.*?(?:<td>)(.*?)(?:<\/td>.*?)(?:<\/tr>)?/m';
$str = '<tr>
<td><5</td>
<td>67</td>
<td>3</td>
<td>0.1</td>
<td>0.6</td>
</tr>
<tr>
<td><13</td>
<td>1.2</td>
<td>2</td>
</tr>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);