// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:<tr>)?.*?(?:<td>)(.*?)(?:<\/td>.*?)(?:<\/tr>)?").unwrap();
let string = "<tr>
<td><5</td>
<td>67</td>
<td>3</td>
<td>0.1</td>
<td>0.6</td>
</tr>
<tr>
<td><13</td>
<td>1.2</td>
<td>2</td>
</tr>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}