use strict;
my $str = '<tr>
<td><5</td>
<td>67</td>
<td>3</td>
<td>0.1</td>
<td>0.6</td>
</tr>
<tr>
<td><13</td>
<td>1.2</td>
<td>2</td>
</tr>
';
my $regex = qr/(?:<tr>)?.*?(?:<td>)(.*?)(?:<\/td>.*?)(?:<\/tr>)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}