import Foundation
let pattern = #"(?:<tr>)?.*?(?:<td>)(.*?)(?:<\/td>.*?)(?:<\/tr>)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<tr>
<td><5</td>
<td>67</td>
<td>3</td>
<td>0.1</td>
<td>0.6</td>
</tr>
<tr>
<td><13</td>
<td>1.2</td>
<td>2</td>
</tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)