import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<tr>)?.*?(?:<td>)(.*?)(?:<\\/td>.*?)(?:<\\/tr>)?";
final String string = "<tr>\n"
+ " <td><5</td>\n"
+ " <td>67</td>\n"
+ " <td>3</td>\n"
+ " <td>0.1</td>\n"
+ " <td>0.6</td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ " <td><13</td>\n"
+ " <td>1.2</td>\n"
+ " <td>2</td>\n"
+ "</tr>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}