const regex = /$(?![\w\W])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('$(?![\\w\\W])', 'gm')
const str = `abc
def
ghi`;
const subst = `text_to_replace`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);