use strict;
my $str = 'abc
def
ghi';
my $regex = qr/$(?![\w\W])/mp;
my $subst = 'text_to_replace';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";