$re = '/$(?![\w\W])/m';
$str = 'abc
def
ghi';
$subst = "text_to_replace";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;