import Foundation
let pattern = #"$(?![\w\W])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc
def
ghi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"text_to_replace"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)