import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([1-4][/][1-4])*)(([,][1-4][/][1-4])*)(([1-4])*)(([,][1-4])*)$";
final String string = "4/1,6/5,6/1,1,2,3,4,5\n"
+ "5,4,3,2,1,1/3,4/4,2/5\n"
+ "2,5,3,2,1,1/3,4/4,2/5asdf\n"
+ "1asdf\n"
+ "4/1\n"
+ "2/3,1,2,3\n"
+ ",2/3,1,2,3\n"
+ "2/3,1,2,3,4,5\n"
+ ",2/3,1,2,3,4,5\n"
+ "5,2/3,1,2,3\n"
+ "4/1,2/3,1,2,3,4,5\n"
+ "1/4,2/3,1,2,3,4,5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}