import Foundation
let pattern = #"^(([1-4][/][1-4])*)(([,][1-4][/][1-4])*)(([1-4])*)(([,][1-4])*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
4/1,6/5,6/1,1,2,3,4,5
5,4,3,2,1,1/3,4/4,2/5
2,5,3,2,1,1/3,4/4,2/5asdf
1asdf
4/1
2/3,1,2,3
,2/3,1,2,3
2/3,1,2,3,4,5
,2/3,1,2,3,4,5
5,2/3,1,2,3
4/1,2/3,1,2,3,4,5
1/4,2/3,1,2,3,4,5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}