re = /^(([1-4][\/][1-4])*)(([,][1-4][\/][1-4])*)(([1-4])*)(([,][1-4])*)$/
str = '4/1,6/5,6/1,1,2,3,4,5
5,4,3,2,1,1/3,4/4,2/5
2,5,3,2,1,1/3,4/4,2/5asdf
1asdf
4/1
2/3,1,2,3
,2/3,1,2,3
2/3,1,2,3,4,5
,2/3,1,2,3,4,5
5,2/3,1,2,3
4/1,2/3,1,2,3,4,5
1/4,2/3,1,2,3,4,5'
# Print the match result
str.match(re) do |match|
puts match.to_s
end