const regex = /^(([1-4][/][1-4])*)(([,][1-4][/][1-4])*)(([1-4])*)(([,][1-4])*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([1-4][\/][1-4])*)(([,][1-4][\/][1-4])*)(([1-4])*)(([,][1-4])*)$', '')
const str = `4/1,6/5,6/1,1,2,3,4,5
5,4,3,2,1,1/3,4/4,2/5
2,5,3,2,1,1/3,4/4,2/5asdf
1asdf
4/1
2/3,1,2,3
,2/3,1,2,3
2/3,1,2,3,4,5
,2/3,1,2,3,4,5
5,2/3,1,2,3
4/1,2/3,1,2,3,4,5
1/4,2/3,1,2,3,4,5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}