# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(([1-4][/][1-4])*)(([,][1-4][/][1-4])*)(([1-4])*)(([,][1-4])*)$"
test_str = ("4/1,6/5,6/1,1,2,3,4,5\n"
"5,4,3,2,1,1/3,4/4,2/5\n"
"2,5,3,2,1,1/3,4/4,2/5asdf\n"
"1asdf\n"
"4/1\n"
"2/3,1,2,3\n"
",2/3,1,2,3\n"
"2/3,1,2,3,4,5\n"
",2/3,1,2,3,4,5\n"
"5,2/3,1,2,3\n"
"4/1,2/3,1,2,3,4,5\n"
"1/4,2/3,1,2,3,4,5")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.