#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^"
Local $sString = ""Cliente1\\Rem\\COB0111111.REM.txt"" & @CRLF & _
""Cliente1\\Rem\\23123123.REM.txt" " & @CRLF & _
""Cliente1\\OK\\COB02222222.REM.txt" " & @CRLF & _
""Cliente1\\Ret\\COB0613062019.REM.txt"" & @CRLF & _
""COB0613062019.REM.txt" " & @CRLF & _
""Cliente2\\COB0613062019.REM.txt"" & @CRLF & _
""Cliente2\\Rem\\COB0633333.REM.txt"" & @CRLF & _
""Cliente2\\Rem\\pasta2\\COB02123123.REM.txt"" & @CRLF & _
""Cliente2\\Bla\\Rem\\COB0613062019.REM.txt"" & @CRLF & _
""Cliente1\\COB0613062019.REM.txt"" & @CRLF & _
""Rem\\COB0613062019.REM.txt" " & @CRLF & _
""Rem"" & @CRLF & _
""Cliente3""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")