use strict;
my $str = '"Cliente1\\\\Rem\\\\COB0111111.REM.txt"
"Cliente1\\\\Rem\\\\23123123.REM.txt"
"Cliente1\\\\OK\\\\COB02222222.REM.txt"
"Cliente1\\\\Ret\\\\COB0613062019.REM.txt"
"COB0613062019.REM.txt"
"Cliente2\\\\COB0613062019.REM.txt"
"Cliente2\\\\Rem\\\\COB0633333.REM.txt"
"Cliente2\\\\Rem\\\\pasta2\\\\COB02123123.REM.txt"
"Cliente2\\\\Bla\\\\Rem\\\\COB0613062019.REM.txt"
"Cliente1\\\\COB0613062019.REM.txt"
"Rem\\\\COB0613062019.REM.txt"
"Rem"
"Cliente3"';
my $regex = qr/^/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}