const regex = /^/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^', 'gmi')
const str = `"Cliente1\\\\Rem\\\\COB0111111.REM.txt"
"Cliente1\\\\Rem\\\\23123123.REM.txt"
"Cliente1\\\\OK\\\\COB02222222.REM.txt"
"Cliente1\\\\Ret\\\\COB0613062019.REM.txt"
"COB0613062019.REM.txt"
"Cliente2\\\\COB0613062019.REM.txt"
"Cliente2\\\\Rem\\\\COB0633333.REM.txt"
"Cliente2\\\\Rem\\\\pasta2\\\\COB02123123.REM.txt"
"Cliente2\\\\Bla\\\\Rem\\\\COB0613062019.REM.txt"
"Cliente1\\\\COB0613062019.REM.txt"
"Rem\\\\COB0613062019.REM.txt"
"Rem"
"Cliente3"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}